On Mon, 16 Jan 2006 11:41:23 -0000, Martijn Faassen <[EMAIL PROTECTED]> wrote:

How urgent is it that all of this works with Zope 2.8? I guess it's urgent if you want to sell it to the Plone community, which will only switch to Zope 2.9 or beyond by next year or so, I expect. How much more often is this kind of thing therefore going to happen?

Zope 2.7 is now the officially supported shipped-with version of Plone 2.1, but we also support Zope 2.8. Many products, including mine, require Zope 2.8 (or usually only Zope 2.7 + Five).

I believe the plan is to require Zope 2.8 and support Zope 2.8 for Plone 2.5 in the same way. I don't really see the problem with this, because Plone 2.5 won't use any of this stuff internally anyway - it's only for add-on products. I have no problem requiring the users of my products to upgrade to Zope 2.9. I would assume that those users who want to use these new features either don't care, or are sophisticated enough to find ways around any particular backwards/forwards compatability problems they may have.

So my vote is, leave Zope 2.8 alone if it's too much hazzle, and put the effort into making sure Plone 2.5 runs flawlessly on Zope 2.9.



Zope-CMF maillist  -  Zope-CMF@lists.zope.org

See http://collector.zope.org/CMF for bug reports and feature requests

Reply via email to