Martin Aspeli wrote:
>> How urgent is it that all of this works with Zope 2.8? I guess it's 
>> urgent if you want to sell it to the Plone community, which will only 
>> switch to Zope 2.9 or beyond by next year or so, I expect. How much
>> more  often is this kind of thing therefore going to happen?
> 
> Zope 2.7 is now the officially supported shipped-with version of Plone 
> 2.1, but we also support Zope 2.8. Many products, including mine,
> require  Zope 2.8 (or usually only Zope 2.7 + Five).

>From what you're saying I deduct that Plone 2.1 favours Zope 2.7 over
2.8. Below you are suggesting that Plone 2.5 should do the same with
Zope 2.8 (favouring it over 2.9). I don't understand why that should be.
If one version has to be favoured at all, it should be the most recent
one. That way it's made clear that the lower version (2.7, 2.8) is only
still supported as a courtesy for those who don't want to upgrade right
now. All other Plone developers and users should preferrably use the
highest stable of Zope, otherwise Plone will continue to lag behind at
least one Zope major release.

> I believe the plan is to require Zope 2.8 and support Zope 2.8 for
> Plone  2.5 in the same way. I don't really see the problem with this,
> because  Plone 2.5 won't use any of this stuff internally anyway - it's
> only for  add-on products. I have no problem requiring the users of my
> products to  upgrade to Zope 2.9. I would assume that those users who
> want to use these  new features either don't care, or are sophisticated
> enough to find ways  around any particular backwards/forwards
> compatability problems they may  have.
> 
> So my vote is, leave Zope 2.8 alone if it's too much hazzle, and put
> the  effort into making sure Plone 2.5 runs flawlessly on Zope 2.9.

That and make the upgrade from Zope 2.7/2.8 to 2.9 flawless as well as
make 2.9 the *recommended* version for Plone 2.5. Then I don't think it
should be much of a problem for Rocky to not have this available in 2.8,
except perhaps if he wants to get started right now, with Plone 2.1
(though that might still run under Zope 2.9 and CMF 1.6, I hope).

Philipp
_______________________________________________
Zope-CMF maillist  -  Zope-CMF@lists.zope.org
http://mail.zope.org/mailman/listinfo/zope-cmf

See http://collector.zope.org/CMF for bug reports and feature requests

Reply via email to