On 12/7/05, Myke C. Subs <[EMAIL PROTECTED]> wrote:
> [EMAIL PROTECTED]:/opt/gnome/bin> ls -l gimptool*
> lrwxrwxrwx  1 root root       12 2005-12-05 11:52 gimptool -> gimptool-2.0
> -rwxr-xr-x  1 root root    10660 2005-11-10 02:00 gimptool-2.0
> lrwxrwxrwx  1 root root       12 2005-12-05 11:52 gimptool-2.2 ->
> gimptool-2.0
> ------------------------------------------------------------------------
> [EMAIL PROTECTED]:~/Downloads/TGZ/Gimp-2.0> perl Makefile.PL
> checking for gimp-2.0... no
> checking for gcc... cc
> checking whether we are using the GNU C compiler... yes
> checking for gimptool-2.0... /opt/gnome/bin/gimptool-2.0
> checking for GIMP - version >= 2.0.0... no
> *** Could not run GIMP test program, checking why...
> *** The test program failed to compile or link. See the file config.log
> for the

What is the output of "tail config.log"?

> *** exact error that occured. This usually means GIMP was incorrectly
> installed
> *** or that you have moved GIMP since it was installed. In the latter
> case, you
> *** may want to edit the gimptool-2.0 script: /opt/gnome/bin/gimptool-2.0
> configure: error: ** unable to find gimp, make sure it's in your path
> (version 1.3.15+ required!)
> ------------------------------------------------------------------------
> I am most concerned at this point about this line in particular from the
> above:
> checking for GIMP - version >= 2.0.0... no
> ...because that's not true.
> Perhaps I should uninstall and then reinstall my GIMP 2.2.9 RPM?

I don't think it has to do with your RPM.  The checks for GIMP that
the source makes assume certain conditions which usually are created
when gimp is built from source.

I'm conserned about this line:
 *** The test program failed to compile or link. See the file config.log

What compiler are you using?  Do you have the development headers for
the libraries used to make gimp?  (Installing gimp-devel should have
brought them in, but...)

> for the

> Or what about rpm --updatedb?

Naw, I don't think the source would check your package manager if GIMP
was installed.

Hum... what if you look for a package called "gimpperl" in YaST? If
it's not there, maybe google for a SuSe RPM for "gimp-perl" (make sure
it matches your OS exactly, since IIRC RPMs can be lethal if they
don't match your distro name and version perfectly).

IIRC, In Ubuntu and Linux, there is a concept of multiple repositries
(e.g. multiple software CDs and/or multiple repositries on the
internet) - maybe YaST needs a similar thing added if gimp-perl is not
already in your OS?

The only problem is, all references to gimp-perl for SuSE 9.2 that I
can find refer to gimp-perl 1.2; Ubuntu is providing something that
looks like a gimp-perl 2.0 so i'm naturally puzzled... *sigh*

 - Just the crazy copy cat.
Gimp-user mailing list

Reply via email to